Board index Barbecue Board General Discussion Brisket Emergency - Help!

Brisket Emergency - Help!

This is the place to ask your BBQ questions, share information, and more.
Post Wed Nov 23, 2005 1:34 am

Posts: 131
Location: Alabama

Got a brisket in the WSM. I noticed my meat temp had only gone up 1 degreee the first hour. I checked and the probe was unplugged from the transmitter. I plugged it back and the meat temp read 150+. No way - not in the first hour. So I moved the probe in the meat. Same result. Checked calibaration on another probe and plugged it in. Same result 150+. What's the deal. I know the meat is not at that temp. What could it be? Could it be probe placement?

HELP!

Ole Smokey
Image
Ole Smokey
www.olesmokeybbq.blogspot.com

Chargriller Super Pro w/SFB
WSM

Post Wed Nov 23, 2005 2:31 am
chrish well done
well done

Posts: 887
Location: Melcher IOWA
yes that would be one problem ive had this happen too but i keep a dial probe just in case
the problem with the digatal ones is that heat shock when its plugged back in.

turn it off and let it cool down to room temp turn it back on put the probe in the grill and worm it up to around 125 and slowly put it back into the meat and it should read right again. also if its cold outside will make them go wacky need to keep it on the grill put a block of wood under it but keep it worm.

hope this helps

Post Wed Nov 23, 2005 10:04 am
The Grill'n Greek well done
well done

Posts: 327
Location: Seattle
Another possability is that you placed the probe to far into the meat and passed the middle and were close to the other side.
ImageImage
Kenmore Elite-gas
Weber table top-gas
CG w SFB
WSM

Post Wed Nov 23, 2005 11:39 am
Bob-BQN User avatar
well done
well done

Posts: 13157
Location: Texas
Ole Smokey BBQ most of use were not concious when you post your plea. How's it going now?
Image


Return to General Discussion